愛悠閑 > emacs-24.1 + cedet-1.1 + ecd-24.0

emacs-24.1 + cedet-1.1 + ecd-24.0

分類: 嵌入式  |  作者: zm_li_share 相關  |  發布日期 : 2015-07-02  |  熱度 : 1137°

 在安裝配置C/C++環境的時候

a.  cedet最新版本為1.1beta,提示cedet-called-interactively-p的參數有問題

  在cedet載入之前          
        add in .emacs configure file .
  (setq byte-compile-warnings nil)       
b. ecb加載的時候顯示錯誤信息,用下列語句屏蔽掉
  (setq stack-trace-on-error nil)
c. ecb提示只兼容cedet版本 1.0.6pre ~ 1.0.9
  在ecb最新版本中找到
修改ecb-upgrade.el文件,將ecb-check-requirements函數中的:(1 0 4 9)
,將最高版本信息改寫一下,比如改為如下
  (defconst ecb-cedet-required-version-max '(1 1 4 9)...


快乐彩中奖说明